<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: DeploymentClient - Unable to send handshake message in Deployment Architecture</title>
    <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56221#M1864</link>
    <description>&lt;P&gt;I have the same issue on 4.3. Everything was working for a few days but now, only the main server is working. All the other forwarders look to be locked out with this issue.&lt;/P&gt;</description>
    <pubDate>Tue, 07 Feb 2012 21:07:45 GMT</pubDate>
    <dc:creator>billynewport</dc:creator>
    <dc:date>2012-02-07T21:07:45Z</dc:date>
    <item>
      <title>DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56219#M1862</link>
      <description>&lt;P&gt;Hello.&lt;/P&gt;

&lt;P&gt;I just installed the Universal Forwarder on a Windows 2K server.  As part of that installation process, I also set up DeploymentClient.conf to point to the Deployment Server, as follows:&lt;/P&gt;

&lt;PRE&gt;&lt;CODE&gt;[target-broker:deploymentServer]
targetUri = &amp;lt;FQDN of Deployment Server&amp;gt;:&amp;lt;tcp port to use&amp;gt;
&lt;/CODE&gt;&lt;/PRE&gt;

&lt;P&gt;But, when I start up Splunk, the log includes the following message:&lt;/P&gt;

&lt;PRE&gt;&lt;CODE&gt;DeploymentClient - Unable to send handshake message to deployment server. Error status is: not_connected
&lt;/CODE&gt;&lt;/PRE&gt;

&lt;P&gt;I have captured packets during Splunk Start execution on the Universal Forwarder, and I &lt;EM&gt;do&lt;/EM&gt; see that the Universal Forwarder machine successfully creates a TCP connection to the Deployment Server, on the designated port, and they converse briefly.  The connection lasts a few tenths of a second, and then the Universal Forwarder machine closes the connection.&lt;/P&gt;

&lt;P&gt;Can anyone suggest why I'm getting the "Unable to send handshake" Warning, and how to resolve it?&lt;/P&gt;

&lt;P&gt;thx,&lt;BR /&gt;
mfeeny1&lt;/P&gt;</description>
      <pubDate>Wed, 10 Aug 2011 18:42:56 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56219#M1862</guid>
      <dc:creator>mfeeny1</dc:creator>
      <dc:date>2011-08-10T18:42:56Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56220#M1863</link>
      <description>&lt;P&gt;I don't know why, but now that my question, above, is on this web site, there is a scroll bar where a line of text used to be.&lt;/P&gt;

&lt;P&gt;So I will re-enter the text...&lt;/P&gt;

&lt;P&gt;Hello.&lt;/P&gt;

&lt;P&gt;I just installed the Universal Forwarder on a Windows 2K server.  As part of that installation process, I also set up DeploymentClient.conf to point to the Deployment Server, as follows:&lt;/P&gt;

&lt;PRE&gt;&lt;CODE&gt;[target-broker:deploymentServer]
targetUri = &amp;lt;FQDN of Deployment Server&amp;gt;:&amp;lt;tcp port to use&amp;gt;
&lt;/CODE&gt;&lt;/PRE&gt;

&lt;P&gt;But, when I start up Splunk, the log includes the following message:&lt;/P&gt;

&lt;PRE&gt;&lt;CODE&gt;DeploymentClient - Unable to send handshake message to deployment server. Error status is: not_connected
&lt;/CODE&gt;&lt;/PRE&gt;

&lt;P&gt;I have captured packets during Splunk Start execution on the Universal Forwarder, and I &lt;EM&gt;do&lt;/EM&gt; see that the Universal Forwarder machine successfully creates a TCP connection to the Deployment Server, on the designated port, and they converse briefly.  The connection lasts a few tenths of a second, and then the Universal Forwarder machine closes the connection.&lt;/P&gt;

&lt;P&gt;Can anyone suggest why I'm getting the "Unable to send handshake" Warning, and how to resolve it?&lt;/P&gt;

&lt;P&gt;Thx,&lt;BR /&gt;
mfeeny1&lt;/P&gt;</description>
      <pubDate>Wed, 10 Aug 2011 20:36:44 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56220#M1863</guid>
      <dc:creator>mfeeny1</dc:creator>
      <dc:date>2011-08-10T20:36:44Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56221#M1864</link>
      <description>&lt;P&gt;I have the same issue on 4.3. Everything was working for a few days but now, only the main server is working. All the other forwarders look to be locked out with this issue.&lt;/P&gt;</description>
      <pubDate>Tue, 07 Feb 2012 21:07:45 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56221#M1864</guid>
      <dc:creator>billynewport</dc:creator>
      <dc:date>2012-02-07T21:07:45Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56222#M1865</link>
      <description>&lt;P&gt;I'm seeing the same thing - unfortunately this is my first time trying out the deployment server. So far I'm pretty unimpressed.&lt;/P&gt;</description>
      <pubDate>Mon, 09 Jul 2012 21:53:19 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56222#M1865</guid>
      <dc:creator>lifetech</dc:creator>
      <dc:date>2012-07-09T21:53:19Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56223#M1866</link>
      <description>&lt;P&gt;I'm having the same problem, but only on a heavy forwarder that is acting as a gateway between our DMZ and internal network.  All of the servers using the deployment client that are internal are fine.&lt;/P&gt;

&lt;P&gt;I've opened firewall port 8089 between the gateway and internal indexer, but am still receiving: Unable to send handshake message to deployment server&lt;/P&gt;</description>
      <pubDate>Wed, 08 Aug 2012 15:06:19 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56223#M1866</guid>
      <dc:creator>jchampagne</dc:creator>
      <dc:date>2012-08-08T15:06:19Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56224#M1867</link>
      <description>&lt;P&gt;I had to create the app to deploy, which I missed in my first try. So in my serverclass.conf I had to put in:&lt;/P&gt;

&lt;P&gt;[serverClass:windows_default]&lt;BR /&gt;
machineTypesFilter = Windows*,windows*&lt;/P&gt;

&lt;P&gt;[serverClass:windows_default:app:windows_default] &amp;lt;-- the app to deploy to the clients.&lt;BR /&gt;
stateOnClient=enabled&lt;BR /&gt;
restartSplunkd=true&lt;/P&gt;</description>
      <pubDate>Mon, 28 Sep 2020 12:13:25 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56224#M1867</guid>
      <dc:creator>lifetech</dc:creator>
      <dc:date>2020-09-28T12:13:25Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56225#M1868</link>
      <description>&lt;P&gt;Was there a solution for this problem? &lt;/P&gt;</description>
      <pubDate>Tue, 02 Oct 2012 12:08:38 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56225#M1868</guid>
      <dc:creator>domteich</dc:creator>
      <dc:date>2012-10-02T12:08:38Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56226#M1869</link>
      <description>&lt;P&gt;I had the same issue on 2 different networks running Splunk 5.0.1&lt;/P&gt;

&lt;P&gt;the first issue was resolved but adding the following to the inputs.conf file on my indexer:&lt;/P&gt;

&lt;P&gt;[splunktcp://9997]&lt;BR /&gt;
connection_host = none&lt;/P&gt;

&lt;P&gt;Also make sure you are not blacklisting anything in your serverclass.conf&lt;BR /&gt;
All frowarders&lt;/P&gt;

&lt;P&gt;[serverClass:all_forwarder]&lt;BR /&gt;
whitelist.0 = *&lt;/P&gt;

&lt;P&gt;The second issue was a network config issue on my ACLs.&lt;/P&gt;

&lt;P&gt;Hope one of these helps&lt;/P&gt;</description>
      <pubDate>Mon, 04 Mar 2013 13:46:43 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56226#M1869</guid>
      <dc:creator>mship</dc:creator>
      <dc:date>2013-03-04T13:46:43Z</dc:date>
    </item>
    <item>
      <title>Re: DeploymentClient - Unable to send handshake message</title>
      <link>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56227#M1870</link>
      <description>&lt;P&gt;In my case, serverclass was correct but the app was not present in the repository.  corrected that issue and restarted splunk on deployment server. &lt;/P&gt;

&lt;P&gt;while the app was missing, clients were getting the handshake error noted above every 60 seconds.  my phoneHomeInterval is set to 4 hours but the handShakeRetry (undefined) was recurring every 60 seconds.  With thousands of deployment clients, the constant retries were overrunning our deployment server.  &lt;/P&gt;

&lt;P&gt;eventually, I got the message "DeploymentClient has been asked to redo-handshake. Resetting to initial state."   after that, the app downloaded and I didn't get the handshake error any more.&lt;/P&gt;

&lt;P&gt;lessons learned?  don't forget to put app in in repository.   don't assume that handShakeRetry tracks with customized phoneHomeIntervalInSecs value.&lt;/P&gt;</description>
      <pubDate>Thu, 19 Sep 2013 01:52:14 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Deployment-Architecture/DeploymentClient-Unable-to-send-handshake-message/m-p/56227#M1870</guid>
      <dc:creator>dstaulcu</dc:creator>
      <dc:date>2013-09-19T01:52:14Z</dc:date>
    </item>
  </channel>
</rss>

