<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: SearcH Head WARN- ConfReplicationThread &amp;amp; ConfMetrics in Splunk Enterprise</title>
    <link>https://community.splunk.com/t5/Splunk-Enterprise/SearcH-Head-WARN-ConfReplicationThread-amp-ConfMetrics/m-p/514963#M3071</link>
    <description>&lt;P&gt;hi&amp;nbsp;&lt;a href="https://community.splunk.com/t5/user/viewprofilepage/user-id/207265"&gt;@venkateshparank&lt;/a&gt;&amp;nbsp;, please check this resolved thread, it seems similar to what you are facing&lt;/P&gt;&lt;P&gt;&lt;A href="https://community.splunk.com/t5/Deployment-Architecture/Search-Head-Cluster-Error-acceptPush-non-200-status-code-400/td-p/333390" target="_blank"&gt;https://community.splunk.com/t5/Deployment-Architecture/Search-Head-Cluster-Error-acceptPush-non-200-status-code-400/td-p/333390&lt;/A&gt;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;</description>
    <pubDate>Wed, 19 Aug 2020 14:34:41 GMT</pubDate>
    <dc:creator>Nisha18789</dc:creator>
    <dc:date>2020-08-19T14:34:41Z</dc:date>
    <item>
      <title>SearcH Head WARN- ConfReplicationThread &amp; ConfMetrics</title>
      <link>https://community.splunk.com/t5/Splunk-Enterprise/SearcH-Head-WARN-ConfReplicationThread-amp-ConfMetrics/m-p/514217#M3027</link>
      <description>&lt;P&gt;Can anyone help why we are seeing these WARN in logs and how to fix permanently.&lt;/P&gt;&lt;P&gt;We are performing manual resync whenever count of events is &amp;gt; 5 in 15mins time range using below query:&lt;BR /&gt;&lt;BR /&gt;index=_internal host=searchhead* component=ConfReplicationThread log_level=WARN "Cannot accept push" |bin span=15m _time|stats max(consecutiveErrors) as count by host,_time|where count&amp;gt;5&lt;/P&gt;&lt;P&gt;LOGS:&lt;/P&gt;&lt;P&gt;==========&lt;/P&gt;&lt;P&gt;WARN ConfReplicationThread - Error pushing configurations to captain=&lt;A href="https://searchhead01.domain.com:8089" target="_blank" rel="noopener"&gt;https://searchhead01.domain.com:8089&lt;/A&gt;, consecutiveErrors=1 msg="Error in acceptPush: Non-200 status_code=400: ConfReplicationException: Cannot accept push with outdated_baseline_op_id=8d89fca5ef4520b00b8ffe8b1366a178b92b52fb; current_baseline_op_id=a948f0e3f0fcae707ce37ca7d7a73"&lt;/P&gt;&lt;P&gt;ConfReplicationThread - Error pushing configurations to captain=&lt;A href="https://searchhead01.domain.com:8089" target="_blank" rel="noopener"&gt;https://searchhead01.domain.com:8089&lt;/A&gt;, consecutiveErrors=1 msg="Error in acceptPush: Non-200 status_code=400: ConfReplicationException: Cannot accept push with outdated_baseline_op_id=66098bdc22c2bcacf951fb104558db365ac64820; current_baseline_op_id=085e675e4c9d8c9fafabee"&lt;/P&gt;&lt;P&gt;ConfReplicationThread - Error pulling configurations from captain=&lt;A href="https://searchhead01.domain.com:8089" target="_blank" rel="noopener"&gt;https://searchhead01.domain.com:8089&lt;/A&gt;, consecutiveErrors=1 msg="Error in fetchFrom, at=a6a747e7138353bd07873f04fe90f2c9b4564567: Network-layer error: Connect Timeout"&lt;/P&gt;&lt;P&gt;ConfReplicationThread - Error pulling configurations from captain=&lt;A href="https://searchhead01.domain.com:8089" target="_blank" rel="noopener"&gt;https://searchhead01.domain.com:8089&lt;/A&gt;, consecutiveErrors=1 msg="Error in fetchFrom, at=a6a747e7138353bd07873f04fe90f2c9b4564567: Network-layer error: Connect Timeout"&lt;/P&gt;&lt;P&gt;ConfReplicationThread - Error pulling configurations from captain=&lt;A href="https://searchhead01.domain.com:8089" target="_blank" rel="noopener"&gt;https://searchhead01.domain.com:8089&lt;/A&gt;, consecutiveErrors=1 msg="Error in fetchFrom, at=a6a747e7138353bd07873f04fe90f2c9b4564567: Network-layer error: Connect Timeout"&lt;/P&gt;&lt;P&gt;=============&lt;/P&gt;&lt;P&gt;Even tried to reduce the max_push count to 50 (default is 100). How can we resolve this permanently ?&lt;/P&gt;&lt;P&gt;==============&lt;/P&gt;&lt;P&gt;WARN ConfMetrics - single_action=PUSH_TO took wallclock_ms=1525! Consider a lower value of conf_replication_max_push_count in server.conf on all members.&lt;BR /&gt;WARN ConfMetrics - single_action=PUSH_TO took wallclock_ms=2644! Consider a lower value of conf_replication_max_push_count in server.conf on all members.&lt;BR /&gt;WARN ConfMetrics - single_action=PULL_FROM took wallclock_ms=2011! Consider a lower value of conf_replication_max_pull_count in server.conf on all members.&lt;BR /&gt;WARN ConfMetrics - single_action=PULL_FROM took wallclock_ms=1778! Consider a lower value of conf_replication_max_pull_count in server.conf on all members.&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;Below are the settings in server.conf&lt;/P&gt;&lt;P&gt;conf_replication_max_push_count = 50&lt;BR /&gt;conf_replication_purge.period = 3h&lt;BR /&gt;conf_replication_period = 10&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;we do not want to do resync everytime.&lt;/P&gt;&lt;P&gt;splunk resync shcluster-replicated-config&lt;/P&gt;</description>
      <pubDate>Sat, 15 Aug 2020 04:53:59 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Splunk-Enterprise/SearcH-Head-WARN-ConfReplicationThread-amp-ConfMetrics/m-p/514217#M3027</guid>
      <dc:creator>venkateshparank</dc:creator>
      <dc:date>2020-08-15T04:53:59Z</dc:date>
    </item>
    <item>
      <title>Re: SearcH Head WARN- ConfReplicationThread &amp; ConfMetrics</title>
      <link>https://community.splunk.com/t5/Splunk-Enterprise/SearcH-Head-WARN-ConfReplicationThread-amp-ConfMetrics/m-p/514963#M3071</link>
      <description>&lt;P&gt;hi&amp;nbsp;&lt;a href="https://community.splunk.com/t5/user/viewprofilepage/user-id/207265"&gt;@venkateshparank&lt;/a&gt;&amp;nbsp;, please check this resolved thread, it seems similar to what you are facing&lt;/P&gt;&lt;P&gt;&lt;A href="https://community.splunk.com/t5/Deployment-Architecture/Search-Head-Cluster-Error-acceptPush-non-200-status-code-400/td-p/333390" target="_blank"&gt;https://community.splunk.com/t5/Deployment-Architecture/Search-Head-Cluster-Error-acceptPush-non-200-status-code-400/td-p/333390&lt;/A&gt;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;</description>
      <pubDate>Wed, 19 Aug 2020 14:34:41 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Splunk-Enterprise/SearcH-Head-WARN-ConfReplicationThread-amp-ConfMetrics/m-p/514963#M3071</guid>
      <dc:creator>Nisha18789</dc:creator>
      <dc:date>2020-08-19T14:34:41Z</dc:date>
    </item>
  </channel>
</rss>

