<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic dns-zoneinfo.ps1&amp;quot; Get-WmiObject : Generic failure   Error on Universal Forwader with DNS and DC TA's in Security</title>
    <link>https://community.splunk.com/t5/Security/dns-zoneinfo-ps1-quot-Get-WmiObject-Generic-failure-Error-on/m-p/143394#M14577</link>
    <description>&lt;P&gt;Issue : On the Domain Controller, customer have the Universal Forwarder  with the TA installed for the DNS and DC. The Splinkd.log file has errors like below&lt;/P&gt;

&lt;P&gt;02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" Get-WmiObject : Generic failure &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" At C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\powe &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" rshell\dns-zoneinfo.ps1:60 char:22 &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" + $RR = Get-WmiObject &amp;lt;&amp;lt;&amp;lt;&amp;lt; -namespace "root\MicrosoftDNS" -class Microsof &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" tDNS_ResourceRecord -ComputerName $env:ComputerName -Filter "DomainName = '$Zon &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" eName'" &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" + CategoryInfo : InvalidOperation: (:) [Get-WmiObject], Managemen &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" tException &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.C &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" ommands.GetWmiObjectCommand &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1&lt;/P&gt;</description>
    <pubDate>Fri, 25 Apr 2014 17:25:32 GMT</pubDate>
    <dc:creator>rbal_splunk</dc:creator>
    <dc:date>2014-04-25T17:25:32Z</dc:date>
    <item>
      <title>dns-zoneinfo.ps1" Get-WmiObject : Generic failure   Error on Universal Forwader with DNS and DC TA's</title>
      <link>https://community.splunk.com/t5/Security/dns-zoneinfo-ps1-quot-Get-WmiObject-Generic-failure-Error-on/m-p/143394#M14577</link>
      <description>&lt;P&gt;Issue : On the Domain Controller, customer have the Universal Forwarder  with the TA installed for the DNS and DC. The Splinkd.log file has errors like below&lt;/P&gt;

&lt;P&gt;02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" Get-WmiObject : Generic failure &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" At C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\powe &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" rshell\dns-zoneinfo.ps1:60 char:22 &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" + $RR = Get-WmiObject &amp;lt;&amp;lt;&amp;lt;&amp;lt; -namespace "root\MicrosoftDNS" -class Microsof &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" tDNS_ResourceRecord -ComputerName $env:ComputerName -Filter "DomainName = '$Zon &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" eName'" &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" + CategoryInfo : InvalidOperation: (:) [Get-WmiObject], Managemen &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" tException &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.C &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1" ommands.GetWmiObjectCommand &lt;BR /&gt;
02-27-2014 16:59:26.225 -0500 ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\etc\apps\TA-DNSServer-NT6\bin\runpowershell.cmd" dns-zoneinfo.ps1&lt;/P&gt;</description>
      <pubDate>Fri, 25 Apr 2014 17:25:32 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Security/dns-zoneinfo-ps1-quot-Get-WmiObject-Generic-failure-Error-on/m-p/143394#M14577</guid>
      <dc:creator>rbal_splunk</dc:creator>
      <dc:date>2014-04-25T17:25:32Z</dc:date>
    </item>
    <item>
      <title>Re: dns-zoneinfo.ps1" Get-WmiObject : Generic failure   Error on Universal Forwader with DNS and DC TA's</title>
      <link>https://community.splunk.com/t5/Security/dns-zoneinfo-ps1-quot-Get-WmiObject-Generic-failure-Error-on/m-p/143395#M14578</link>
      <description>&lt;P&gt;Resolution:   The problem is likely to be permissions, and the issue resolved after we restarted the splunk service as local SYSTEM user. After switching the SplunkForwarder service to run as the local system account, this error went away and DNS data started to flow  into the AD and Windows Infrastructure Apps.&lt;/P&gt;</description>
      <pubDate>Fri, 25 Apr 2014 17:26:16 GMT</pubDate>
      <guid>https://community.splunk.com/t5/Security/dns-zoneinfo-ps1-quot-Get-WmiObject-Generic-failure-Error-on/m-p/143395#M14578</guid>
      <dc:creator>rbal_splunk</dc:creator>
      <dc:date>2014-04-25T17:26:16Z</dc:date>
    </item>
  </channel>
</rss>

